Page 1 of 1

New Install and getting errors

Posted: 2016-06-08T10:21:33-07:00
by Scotts
Hi. I have been trying to figure this out. I have code that works perfectly on my current production server. Perl 5.8.8, ImageMagick 6.3.2 Q16, Windows server 2008. All 32-bit

The new server is Perl 5.22, Windows Server 2012, ImageMagick-7.0.1-9-Q16-x64-dll, PerlMagick 6.89-1 (Latest i could find) This server is 64-bit and all code installed thus far is 64-bit. When I run my code I get the following:

Exception 495: RegistryKeyLookupFailed `CoderModulesPath' @ error/module.c/GetMagickModulePath/664 at line 481.
Can't locate object method "Crop" via package "Exception 410: NoImagesDefined `Image::Magick' @ error/Magick.xs/unknown/2949" (perhaps you forgot to load "Exception 410: NoImagesDefined `Image::Magick' @ error/Magick.xs/unknown/2949"?) at line 492.

I have tried creating a MAGICK_CODER_MODULE_PATH environment variable and setting it to C:\Program Files\ImageMagick-7.0.1-Q16\modules\coders as well as C:\Program Files\ImageMagick-7.0.1-Q16\modules

ImageMagick works fine from the command line so it is something with running from PERL. Nothing I have done gets me around this.. Any help from the vast knowledge out there would be awesome.

Thanks, Scott

Re: New Install and getting errors (RegistryKeyLookupFailed `CoderModulesPath')

Posted: 2018-09-02T09:57:12-07:00
by perl-master
Has anyone seen this and/or solved this?

I have a fresh Windows 10 Pro as a VirtualBox guest with
This is perl 5, version 26, subversion 1 (v5.26.1) built for MSWin32-x64-multi-thread
(with 1 registered patch, see perl -V for more detail)

Copyright 1987-2017, Larry Wall

Binary build 2601 [404865] provided by ActiveState
Built Dec 11 2017 12:23:25
(the dynamic version didn't work at all failing with the unable to load DLL) and

Code: Select all

ppm install PerlMagick
When trying to read an image I get the error

Code: Select all

Exception 495: RegistryKeyLookupFailed `CoderModulesPath' @ error/module.c/GetMagickModulePath/664
I tried to manually add the key to the registry (where it seemed to be missing) but that didn't fix the problem. Are there instructions somewhere for adding the key and value?

Thanks for any help

Re: New Install and getting errors

Posted: 2018-09-02T10:43:07-07:00
by snibgo
I don't think registry keys are explicitly documented, but "registry" occurs often in

The registry keys should be set by the installation, when you run ImageMagick-7.0.8-11-Q16-x64-static.exe.

For your info, my Windows 8.1 laptop has:

Code: Select all

f:\web\im>reg  query "HKLM\Software\ImageMagick\Current" /s

    Version    REG_SZ    6.9.9
    QuantumDepth    REG_DWORD    0x10
    BinPath    REG_SZ    C:\im\ImageMagick-6.9.9-50-Q16
    ConfigurePath    REG_SZ    C:\im\ImageMagick-6.9.9-50-Q16
    LibPath    REG_SZ    C:\im\ImageMagick-6.9.9-50-Q16
    CoderModulesPath    REG_SZ    C:\im\ImageMagick-6.9.9-50-Q16\modules\coders
    FilterModulesPath    REG_SZ    C:\im\ImageMagick-6.9.9-50-Q16\modules\filters
You may prefer the portable version, which doesn't use the registry.

Re: New Install and getting errors

Posted: 2018-09-09T09:39:30-07:00
by perl-master
Thanks for the responses. I have a little more progress.

A) ImageMagick-7.0.8-11-Q8-x64-dll doesn't seem to have a modules/coders folder, so I'm guessing that it is totally incompatible with the latest ActiveState PerlMagick build.

B) I was able to find a 6.9.10 download for ImageMagick, and make a little progress with setting
MAGICK_CODER_MODULE_PATH='C:\Program Files\ImageMagick-6.9.10-Q16\modules\coders'
MAGICK_HOME='C:\Program Files\ImageMagick-6.9.10-Q16'

However, it still doesn't run:

Exception 455: UnableToLoadModule `C:\Program Files\ImageMagick-6.9.10-Q16\modules\coders\IM_MOD_RL_JPEG_.dll': The specified procedure could not be found.

Is it the case that PerlMagick version 6.89-1 having been built on Sep 21st, 2014 is completely incompatible with any recent officially downloadable ImageMagick version? Is there a safe place to download a compatible ImageMagick?


Re: New Install and getting errors

Posted: 2019-08-05T11:22:55-07:00
by thetrekker
Have you resolved this issue?