[RESOLVED]bug in IM 7 monochrome vs IM 6 monochrome

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
fmw42
Posts: 26261
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

[RESOLVED]bug in IM 7 monochrome vs IM 6 monochrome

Post by fmw42 »

IM 7.0.9.13 -monochrome has the opposite polarity (it is negated) from that produced by IM 6.9.10.83 Q16 Mac OSX Sierra. IM 6 is the correct result, which can be seen by comparing to the grayscale version of the input and looking to see where it is <50% gray and >50% gray.

Input:
Image

Code: Select all

convert lena.jpg -monochrome lena_mono6.jpg
Image

Code: Select all

magick lena.jpg -monochrome lena_mono7.jpg
Image

User avatar
magick
Site Admin
Posts: 11215
Joined: 2003-05-31T11:32:55-07:00

Re: bug in IM 7 monochrome vs IM 6 monochrome

Post by magick »

Thanks for the problem report. We can reproduce it and will have a patch to fix it in GIT master branch @ https://github.com/ImageMagick/ImageMagick later today. The patch will be available in the beta releases of ImageMagick @ https://www.imagemagick.org/download/beta/ by sometime tomorrow.

User avatar
fmw42
Posts: 26261
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: bug in IM 7 monochrome vs IM 6 monochrome

Post by fmw42 »

Thanks. Seems to be fixed in IM 7.0.9.14

Post Reply