Spelling of 'tIME' in output of 'identify -verbose' ?

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Locked
pipitas
Posts: 168
Joined: 2012-07-15T14:06:46-07:00
Authentication code: 15

Spelling of 'tIME' in output of 'identify -verbose' ?

Post by pipitas »

This is a 'MacPorts' installation of ImageMagic on a MacBook:

Code: Select all

identify -version
  Version: ImageMagick 6.9.0-0 Q16 x86_64 2014-12-06 http://www.imagemagick.org
  [....]
I've just noticed this weird spelling of 'tIME' in the output of 'identify -verbose'. I wonder if it is just a harmless typo in the sources, or if it is there for some reason:

Code: Select all

identify -verbose wiz.png | grep -i png:time
      png:tIME: 2015-01-22T11:55:41Z
If it is just a typo, it has of course no high priority to fix. If the typo however is accompanied by some other (so far un-noticed) typos in the surrounding source lines, it may be worth while to take a closer look.

User avatar
dlemstra
Posts: 1625
Joined: 2013-05-04T15:28:54-07:00
Authentication code: 6789
Contact:

Re: Spelling of 'tIME' in output of 'identify -verbose' ?

Post by dlemstra »

This might look like a typo but it is the correct spelling of the tag, more info can be found here: http://www.sno.phy.queensu.ca/~phil/exi ... s/PNG.html
.NET + ImageMagick = Magick.NET https://github.com/dlemstra/Magick.NET, @MagickNET, Donate

pipitas
Posts: 168
Joined: 2012-07-15T14:06:46-07:00
Authentication code: 15

Re: Spelling of 'tIME' in output of 'identify -verbose' ?

Post by pipitas »

dlemstra wrote:This might look like a typo but it is the correct spelling of the tag, more info can be found here: http://www.sno.phy.queensu.ca/~phil/exi ... s/PNG.html
Oh... Interesting!

Thanks for the info. :)

Locked