Trouble recompiling

Questions and postings pertaining to the development of ImageMagick, feature enhancements, and ImageMagick internals. ImageMagick source code and algorithms are discussed here. Usage questions which are too arcane for the normal user list should also be posted here.
Locked
DiegoFleitas
Posts: 3
Joined: 2019-07-24T13:27:03-07:00
Authentication code: 1152

Trouble recompiling

Post by DiegoFleitas »

Hi, I'm trying to use LiquidRescaleImage on my CentoOS server but I'm not being able to, this is the error I'm getting:

Code: Select all

delegate library support not built-in '/var/www/html/contentawarebot/deployment/src/resources/frames/original/frame0.jpg' (LQR) @ error/resize.c/LiquidRescaleImage/2032
Dirk explained to me for it to work I need to
recompile it with glib and liblqr support
But I'm not sure how to do that. I've tried using

Code: Select all

make distclean
and then rebuilding it as such

Code: Select all

./ImageMagick-7.0.8-53/configure --with-lqr
make
make install
When I check with

Code: Select all

convert -list configure | grep -i "delegates"
nothing seems to have changed

Sorry If I didn't explain my problem properly my knowledge on this is very limited, thanks

User avatar
fmw42
Posts: 26383
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Trouble recompiling

Post by fmw42 »

You have compiled from source, it would appear. So you get no delegates. You have to install all desired delegates from source before installing Imagemagick. You likely need to build an RPM. See

https://imagemagick.org/script/install-source.php#unix
https://imagemagick.org/script/advanced ... lation.php

Or install from some binary that has lqr built in. See

https://imagemagick.org/script/download.php

Sorry, I am not a Linux user, so cannot help further.

DiegoFleitas
Posts: 3
Joined: 2019-07-24T13:27:03-07:00
Authentication code: 1152

Re: Trouble recompiling

Post by DiegoFleitas »

I'll try installing the binaries assuming ImageMagick-7.0.8-56.x86_64.rpm has what I need, I'll post a reply here If i make progress, thanks

EDIT: Oops those are for x64 systems, I'm limited to 32bits since It's an old laptop I had lying there. Back to RPM

DiegoFleitas
Posts: 3
Joined: 2019-07-24T13:27:03-07:00
Authentication code: 1152

Re: Trouble recompiling

Post by DiegoFleitas »

Tried
./configure '--with-modules' '--enable-shared' '--with-perl' '--with-lqr' '--with-gslib'
with no success, then i figured I didn't have lqr installed.

Downloaded it from here http://liblqr.wdfiles.com/local--files/ ... .2.tar.bz2 following the installation steps described on the webpage. The installation failed because I was missing glib2-devel too, after installing that too I managed to install lqr.

And when I rebuilt with the first command it worked! I'm suprised I pulled this off! thanks for the links those helped a lot

Locked