setFont not working

IMagick is a native PHP extension to create and modify images using the ImageMagick API. ImageMagick Studio LLC did not write nor does it maintain the IMagick extension, however, IMagick users are welcome to discuss the extension here.
Locked
NeoTrix
Posts: 2
Joined: 2014-08-25T06:15:58-07:00
Authentication code: 6789

setFont not working

Post by NeoTrix »

Hey guys,
I have a problem with the setFont command in PHP,
no matter what font file I give him, it won't recognize it.
Of course I'm giving him the full path + font file name itself, and it gets it (If i put something that not exists, I'm getting an PHP error of course).
So no problems at all with the font path.
What it does do actually, it looks like it takes some default font from the system and uses it. But of course I need other fonts.
I'm running on a shared hosting plan, so I don't have SSH access to make actions if needed, and PHP's version is 5.4. And I have the newest version of ImageMagick installed on the server.
Have to admit that before we moved to this shared hosting, we were hosted on our VPS (& PHP 5.5), and it all worked fine.

Do you familiar with this bug?
Thanks!

NeoTrix
Posts: 2
Joined: 2014-08-25T06:15:58-07:00
Authentication code: 6789

Re: setFont not working

Post by NeoTrix »

All fixed!
My provider told me they double checked the configurations and they found out that one of the clasees of IM was problematic,
so they just re-compiled IM and fixed the problem.

Thanks anyway.

Locked