Install / Compiling Magickwand for PHP (Debain) ...

MagickWand for PHP is an object-oriented PHP interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning MagickWand for PHP.
Locked
MARTES

Install / Compiling Magickwand for PHP (Debain) ...

Post by MARTES »

=== Situation ===
We have 2 servers with Debian.
Server A is running with attached php_A.ini > phpinfo gives attached output phpinfo_server_A.png

=== Task ===
Install Magickwand for PHP on Server B
before we compile the Magickwand for PHP, we compiled ImageMagick 6.3.7 with ./configure-parameter quantum-depth=Q8
we need this speciall configuration-parameter with 8bit instead of the default 16bit.

so now we install Magickwand for PHP
1.) wget sourcefile from your site
2.) mkdir and unpack sourcefile
3.) phpize and ./configure (without any extra parameters)
4.) make and make install
5.) restart apache2

the results in Server B is running with attached php_A.ini > phpinfo gives attached output phpinfo_server_B.png

=== Problem ===
When we try to load a picture over the MagickWand we get an error-message: the image-format is not supported. How is it possible to get the MagickWand supported image formats?
(see attached file: server_A_B_differences.png)

Can anybody help?

attachments can downloaded here: http://www.martes.de/attachments.rar

Sincercly Manuel
manuel@martes.de

User avatar
magick
Site Admin
Posts: 11254
Joined: 2003-05-31T11:32:55-07:00

Re: Install / Compiling Magickwand for PHP (Debain) ...

Post by magick »

Type
  • convert -list format
to get a list for supported formats. If a particular image format is missing, you must rebuild ImageMagick from source and check the output of the configure script. It tells you if a particular image format is validated. If not, check config.log to determine why the validation failed. Now fix the problem and rerun the ImageMagick configure script until the validation passes. Now then you reinstall, you will be able to use the format within ImageMagick.

Locked