Page 1 of 2

OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-09-28T18:07:49-07:00
by BlueWave95
OSX 10.14.5
XCode 11.0
XQuartz 2.7.11 (xorg-server 1.18.4)

ImageMagick-x86_64-apple-darwin17.7.0.tar.gz
17546 KB 9/22/18 8:00:00 PM EDT
-----------------

Hi, I'm new to ImageMagick and I obtained ImageMagick from the FTP site. Commands magick and identity appear to work just fine but the display command gives me the following error:

Code: Select all

display: delegate library support not built-in '' (X11) @ error/display.c/DisplayImageCommand/1900
I'm not sure what to do about this. Is the display command necessary for the functionality of ImageMagick?

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-09-28T18:11:00-07:00
by fmw42
What do you get from

Code: Select all

magick -version
Did you

Code: Select all

export DISPLAY=:0
as mentioned at https://imagemagick.org/script/download.php#macosx along with the other instructions.

Add that to your .profile or .bash_profile.

Does it work then?

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-09-28T18:20:28-07:00
by BlueWave95
Hello..

Here's the version info

Code: Select all

$ magick -version
Version: ImageMagick 7.0.8-9 Q16 x86_64 2018-08-04 https://www.imagemagick.org
Copyright: © 1999-2018 ImageMagick Studio LLC
License: https://www.imagemagick.org/script/license.php
Features: Cipher DPC HDRI 
Delegates (built-in): bzlib freetype jng jpeg lcms png raw tiff webp xml zlib
Yes I did set the DISPLAY variable.

Code: Select all

$ echo $DISPLAY
:0
Yep I looked at those instructions and set the variables as indicated:

Code: Select all

export MAGICK_HOME="$HOME/Downloads/ImageMagick-7.0.8"
export PATH="$MAGICK_HOME/bin:$PATH"
export DYLD_LIBRARY_PATH="$MAGICK_HOME/lib/"
export DISPLAY=:0
Did it look like I missed something?

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-09-28T19:18:13-07:00
by fmw42
Did you install Xcode Tools?

Did you launch XQuartz before you did your display. It has to be started. ImageMagick display will not automatically start it.

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-09-29T14:44:43-07:00
by BlueWave95
Did you install Xcode Tools?
Yes.

Code: Select all

$ xcode-select -p
/Applications/Xcode.app/Contents/Developer
Did you launch XQuartz before you did your display. It has to be started. ImageMagick display will not automatically start it.

Yep it's running.

I've tried running the display command from within the XQuart xterm window and the error persists.

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-09-29T15:07:11-07:00
by fmw42
You should launch XQuartz, but still issue your commands in the normal Mac Terminal Window, which should be a bash window.

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-09-29T16:23:12-07:00
by BlueWave95
ugh.. I gave up with the binary package for mac, it just doesn't appear to be compiled correctly for osx.

I instead downloaded the source and compiled it myself. I read the Install-mac.txt file to download some of the delegates first.

I did a configure, make clean, make, make install, switched to my install folder, setup my environment variables.. and (phew!) display finally worked. Magick and identify commands appear to work ok as well. Hopefully I won't run into any other issues later.

FYI. The configure command I used:

Code: Select all

./configure CPPFLAGS='-I/opt/local/include' LDFLAGS='-L/opt/local/lib'   --enable-delegate-build --enable-shared --disable-static   --with-modules --with-quantum-depth=16 --enable-hdri --with-gslib   --disable-silent-rules --disable-dependency-tracking --with-rsvg --with-gs-font-dir=/opt/local/share/ghostscript/fonts/ --with-x --prefix=${HOME}/bin/ImageMagick7.0.8-65

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-09-29T16:35:44-07:00
by BlueWave95
Thank you fmw42 for your input in trying to help me get this running!

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-09-29T17:49:12-07:00
by fmw42
You said your version was OSX 10.14 Mojave. But the only version of ImageMagick binary for Mac on the Binary page at https://imagemagick.org/script/download.php#macosx says:

ImageMagick-x86_64-apple-darwin17.7.0.tar.gz download download macOS High Sierra

So that may be your issues.


The way I do it is to install all my delegated from MacPorts and then install manually from source. Here is a post I made a while back, but I used the same method with a different compiler for my current Sierra version and I expect with the proper compiler will also work for current versions of Mac OSX. https://www.imagemagick.org/discourse-s ... rts#p88202

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-12-10T20:45:44-07:00
by user001
Hey BlueWave95. I've also found the ImageMagick binary for Mac to be broken for some time (X11 support was working in the past). Thanks for posting your install route. What did you put in /opt/local/{include,lib} ? Just the delegates suggested by Install-mac.txt? (freetype +bytecode, librsvg, graphviz +gs +wmf +jbig +jpeg2 +lcms) Did you use MacPorts for those or can they be easily obtained without a package manager? Cheers.

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-12-19T08:08:22-07:00
by passereve
Hello everyone,
I am a new ImageMagick user.

Mac OS 10.15.2
ImageMagick 7.0.9-8 Q16 x86_64 2019-12-09
XQuartz 2.7.11

I have the same problem :
display: delegate library support not built-in '' (X11) @ error / display.c / DisplayImageCommand / 1877.


Have you identified the error?

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-12-19T08:36:34-07:00
by magick
Rerun the configure script from the command-line. Carefully check config.log. It looks like the configure script did not find your X11 header files or could not link to the X11 libraries. The exception in the log file will tell you why the validation failed. Fix the problem and rerun the configure script until X11 is validated. Now build/install and the display program will work.

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-12-19T09:39:00-07:00
by passereve
I installed imagemagick from brew: <brew install imagemagick>.
I don't know how to find the configuration file and follow your advice.
Thanks for your help.

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2019-12-19T10:36:57-07:00
by fmw42
Do you have Xcode.app on your system? See the comment about X11 server at https://imagemagick.org/script/download.php#macosx. You should get that from Apple or your install disk if you have one. Then try installing from Homebrew again if your imagemagick commands do not work. You also need to export DISPLAY=:0 as mentioned in the same paragraph in that link.

Re: OSX - display: delegate library support not built-in '' (X11)

Posted: 2020-03-04T23:19:55-07:00
by fastsailing
Same issue here:
  • MacOS 10.15.3
  • XCode 11.3.1
  • XQuartz 2.7.11 (running)
  • homebrew install of ImageMagick
To be sure:

Code: Select all

> echo $DISPLAY
:0
... and...

Code: Select all

> brew reinstall imagemagick
==> Reinstalling imagemagick 
==> Downloading https://homebrew.bintray.com/bottles/imagemagick-7.0.9-27.catali
[...]
==> Pouring imagemagick-7.0.9-27.catalina.bottle.tar.gz
🍺  /usr/local/Cellar/imagemagick/7.0.9-27: 1,480 files, 24.8MB
But still...

Code: Select all

> magick logo: logo.gif
> identify logo.gif
logo.gif GIF 640x480 640x480+0+0 8-bit sRGB 256c 28576B 0.000u 0:00.000
> display logo.gif
Version: ImageMagick 7.0.9-27 Q16 x86_64 2020-03-04 https://imagemagick.org
[...]
display: delegate library support not built-in '' (X11) @ error/display.c/DisplayImageCommand/1877.
I'm unsure where to go from here, any suggestions please? OR have any of the above folks with the same problem solved it?
Thanks in advance.